Upgrade to 2.93 breaks web reports

Hello,

I upgraded to 2.93 and I get the first error. So I checked the application pool and it was set to classic and the default website was set for default. I am able to login if I set them both the same either classic or default but they have to match. I am not sure if this changed with the upgrade because I did not change them and it worked fine before the upgrade. So I make them match and I can login again but every search is now broken. I recieve the second error below. I found a refernence to this error to enable buffering to true and that is already set to true. This is on 2008 R2 BTW.

Thanks

Dave

First error:

HTTP Error 403.18 - Forbidden
The specified request cannot be processed in the application pool that is configured for this resource on the Web server. Detailed Error InformationModule IIS Web Core
Notification BeginRequest
Handler StaticFile
Error Code 0x00000000
Requested URL https
Physical Path C:\PROGRA~2\EVENTS~1\Web\
Logon Method Not yet determined
Logon User Not yet determined

Second error:

error 'ASP 0156 : 80004005'
Header Error

/eventsentry/eventsentry_db.asp, line 2913

The HTTP headers are already written to the client browser. Any HTTP header modifications must be made before writing page content.

Comments

  • Hi David,

    Please try setting the managed pipeline mode from Classic to Integrated. You are correct the second error should be resolved by enabling buffering. It is possible this error will be resolved by restarting IIS.

    I would try renaming the web.config file to web.config.bk before restarting IIS to see if the configuration options are affecting the web reports.

    I hope this helps.
  • Hey Ryan,

    When I switched the app pool to default it was set to integraded. I have since rebooted the server and re-started IIS many times with the same result. I did as you sugessted and renamed the web.config file and did an IIS restart and when I went to the site I recieved 403 - Forbidden: Access is denied.

    Thanks

    Dave
  • BTW the site is up and I can login and see data but all search functions are not working.

    Thanks

    Dave
  • Hi David,

    I'm glad to hear that the site itself is up. Are you getting any error messages when you are attempting a search? Could you please post those here?

    Thanks.
  • Hey Ingmar,

    It is the second error posted above.

    Thanks

    Dave
  • Thank you for trying those suggestions. Regarding the Access Denied error, please verify that Anonymous Authentication is enabled in IIS and the files for the web reports have the correct permissions.

    Please see the following Knowledge Base article for more information:
    http://www.eventsentry.com/kb/169

    It may be worth it to try enabling buffering for both EventSentry Virtual Directory and the Web Site it is hosted under.

    Please see the following Knowledge Base article for more information:
    http://www.eventsentry.com/kb/161
  • Hello Ryan,

    I did what you said and it fixed the access denied error. Also enabling buffering for the default site fixed the search error I was getting. So thank you.

    Dave
  • Sorry for hijacking this post, but we experience the same problems (access denied after upgrade) and the suggestions in this thread won't help.
    Any further options?
  • Spoke too soon, was I changed the application pool of the virtual directory to the DefaultAppPool, everything worked.
Sign In or Register to comment.